Convertir fecha en EPOCH


Escenario

Tenemos una fichero CSV o en formato Hoja de Cálculo donde una columna tiene la fecha en formato EPOCH (son los números de segundos o milisegundos desde la fecha actual hasta la fecha actual) y la cual queremos convertir en formato fecha DD/MM/AAAA h:mm:ss donde:

  • DD son los días en dos dígitos
  • MM es el mes en dos dígitos
  • AAAA es el año con cuatro dígitos
  • h es la hora
  • mm son los minutos
  • ss son los segundos

En nuestro escenario vamos a convertir la fecha EPOCH siguiente 1301773578685

Procedimiento

Advertencia: Debemos determinar si la fecha EPOCH está en milisegundos

  1. Determinar si la fecha EPOCH está definida en milisegundos: En este paso nos ayudaremos de un convertidor Web http://www.epochconverter.com/, aunque definiremos la fórmula para que detecte si la fecha
  2. Definir la formula para convertir fecha EPOCH: supondremos que vamos a realizar la conversión en MS Excel y la formula sería la siguiente, suponiendo que la celda con la fecha EPOCH es la celda A2:

    =SI(ENTERO(A2/1000)>0;(ENTERO(A2/1000)/(24*60*60)) + “01/01/1970 0:00:00”;0)

    fecha epoch

    Formula para la Conversión de la fecha EPOCH

  3. Formato de la Celda: La celda con la formula puede mostrar en formato número, por ello le asignaremos un formato personalizado de fecha del tipo DD/MM/AAAA h:mm

    formato fecha EPOCH

    Asignación de formato para la fecha EPOCH convertida

Enlaces de Interés

Para más información visitar el siguiente:

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s